incompatible qt 4.8.6 with OS X El Capitan‎

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

incompatible qt 4.8.6 with OS X El Capitan‎

criskross
This post has NOT been accepted by the mailing list yet.
Hi developers,

I am experiencing incompatibility notifications while trying to install qt 4.8.6 libraries.

I am using OS X El Capitan‎


Incompatibility notification qt

Any ideas, what I can do?

Kind regards,
Christian
Reply | Threaded
Open this post in threaded view
|

Re: incompatible qt 4.8.6 with OS X El Capitan‎

Isaiah Norton-2
4.8.7 doesn't present compat warnings, and is available from here:

I ended up installing qt 4.8.7 and XQuartz from homebrew, which works fine.

(although the retina/high-DPI support seems inconsistent. we already set NSHighResolutionCapable so I guess this is probably widget issues and might not really addressable until the switch to Qt5)

On Thu, Nov 12, 2015 at 1:01 PM, criskross <[hidden email]> wrote:
Hi developers,

I am experiencing incompatibility notifications while trying to install qt
4.8.6 libraries.

I am using *OS X El Capitan‎*


<http://slicer-devel.65872.n3.nabble.com/file/n4035551/Screen_Shot_2015-11-12_at_12.png>

Any ideas, what I can do?

Kind regards,
Christian



--
View this message in context: http://slicer-devel.65872.n3.nabble.com/incompatible-qt-4-8-6-with-OS-X-El-Capitan-tp4035551.html
Sent from the slicer-devel mailing list archive at Nabble.com.
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ


The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at
http://www.partners.org/complianceline . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ


The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at
http://www.partners.org/complianceline . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.
Reply | Threaded
Open this post in threaded view
|

Re: incompatible qt 4.8.6 with OS X El Capitan‎

criskross
I have the same issues even when I use version 4.8.7



--
View this message in context: http://slicer-devel.65872.n3.nabble.com/incompatible-qt-4-8-6-with-OS-X-El-Capitan-tp4035551p4035554.html
Sent from the slicer-devel mailing list archive at Nabble.com.
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ


The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at
http://www.partners.org/complianceline . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.

Reply | Threaded
Open this post in threaded view
|

Re: incompatible qt 4.8.6 with OS X El Capitan‎

criskross
This post has NOT been accepted by the mailing list yet.
In reply to this post by Isaiah Norton-2
I have the same issues even when I use version 4.8.7
Reply | Threaded
Open this post in threaded view
|

Re: incompatible qt 4.8.6 with OS X El Capitan‎

Isaiah Norton-2
In reply to this post by criskross
Ah, I see the warning and then failure now. I hadn't run the installer far enough.

It looks like homebrew and macports wrote some patches (the homebrew one is small, at least) to get qt4 to build against the 10.11 SDK: 


So you could either compile qt yourself and apply one of those patches, or install from homebrew. There is no discussion of homebrew on the Slicer build instructions, but so far it seems to work fine (I only built on 10.11 last night, didn't run any tests).

On Thu, Nov 12, 2015 at 2:16 PM, criskross <[hidden email]> wrote:
I have the same issues even when I use version 4.8.7



--
View this message in context: http://slicer-devel.65872.n3.nabble.com/incompatible-qt-4-8-6-with-OS-X-El-Capitan-tp4035551p4035554.html
Sent from the slicer-devel mailing list archive at Nabble.com.
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ


The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at
http://www.partners.org/complianceline . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.



_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ


The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at
http://www.partners.org/complianceline . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.